summary refs log tree commit diff
path: root/debian/rules
diff options
context:
space:
mode:
authorRichard van der Hoff <richard@matrix.org>2018-12-20 11:33:29 +0000
committerRichard van der Hoff <richard@matrix.org>2018-12-20 11:33:29 +0000
commit1a6d5bfa08b4ba618dcab68e4ed524c4db07da2b (patch)
treec29f79003b2ff7bd8a26d5dcbdf44a1f96a71fed /debian/rules
parentimport from package-debian-synapse (diff)
downloadsynapse-1a6d5bfa08b4ba618dcab68e4ed524c4db07da2b.tar.xz
Debian packaging via dh_virtualenv (#4285)
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 16 insertions, 12 deletions
diff --git a/debian/rules b/debian/rules
index ad0e95c83d..05cbbdde08 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,18 +1,22 @@
 #!/usr/bin/make -f
+#
+# Build Debian package using https://github.com/spotify/dh-virtualenv
+#
 
-# This file was automatically generated by stdeb 0.8.2 at
-# Fri, 12 Jun 2015 14:32:03 +0100
-export PYBUILD_NAME=matrix-synapse
-%:
-	dh $@ --with python2 --with systemd --buildsystem=pybuild --no-guessing-deps
+override_dh_systemd_enable:
+	dh_systemd_enable --name=matrix-synapse
 
-override_dh_auto_install:
-	python setup.py install --root=debian/matrix-synapse --install-layout=deb
+override_dh_installinit:
+	dh_installinit --name=matrix-synapse
 
-override_dh_auto_build:
+override_dh_strip:
 
-override_dh_installinit:
-	dh_installinit --no-start
+override_dh_shlibdeps:
 
-override_dh_auto_test:
-	PYTHONPATH=. trial tests
+override_dh_virtualenv:
+	./debian/build_virtualenv
+
+# We are restricted to compat level 9 (because xenial), so have to
+# enable the systemd bits manually.
+%:
+	dh $@ --with python-virtualenv --with systemd