summary refs log tree commit diff
path: root/debian/rules
diff options
context:
space:
mode:
authorRichard van der Hoff <richard@matrix.org>2018-12-20 11:35:23 +0000
committerRichard van der Hoff <richard@matrix.org>2018-12-20 11:35:23 +0000
commitd3c9c562c60133a2263b36376aa854064630589d (patch)
tree18d0efeecdbc24f33367f87a2a86aa90f854d3ec /debian/rules
parentAdd 'sandbox' to CSP for media repo (#4284) (diff)
parentDebian packaging via dh_virtualenv (#4285) (diff)
downloadsynapse-d3c9c562c60133a2263b36376aa854064630589d.tar.xz
Debian packaging via dh_virtualenv
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000000..05cbbdde08
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+#
+# Build Debian package using https://github.com/spotify/dh-virtualenv
+#
+
+override_dh_systemd_enable:
+	dh_systemd_enable --name=matrix-synapse
+
+override_dh_installinit:
+	dh_installinit --name=matrix-synapse
+
+override_dh_strip:
+
+override_dh_shlibdeps:
+
+override_dh_virtualenv:
+	./debian/build_virtualenv
+
+# We are restricted to compat level 9 (because xenial), so have to
+# enable the systemd bits manually.
+%:
+	dh $@ --with python-virtualenv --with systemd