summary refs log tree commit diff
path: root/debian/rules
diff options
context:
space:
mode:
authorJörg Behrmann <behrmann@physik.fu-berlin.de>2022-08-26 10:10:54 +0200
committerGitHub <noreply@github.com>2022-08-26 08:10:54 +0000
commit998e211836b99cbe3d07e594c3c3d1d4ebea5aae (patch)
treee62e7a5516aea764922f5fbd8d2a980c2b0b71d6 /debian/rules
parentMove the execution of the retention purge_jobs to the main worker (#13632) (diff)
downloadsynapse-998e211836b99cbe3d07e594c3c3d1d4ebea5aae.tar.xz
Update debhelper (#13594)
* Update debian packaging to debhelper version 12

Don't call dh_installinit anymore, because it has been deprecated, and use
dh_installsystemd instead of dh_systemd_enable for the same reason.

Signed-off-by: Jörg Behrmann <behrmann@physik.fu-berlin.de>

* Drop preinst script

It was used for reasons of interactions of dh_systemd_start and dh_installinit,
which have both be deprecated

Signed-off-by: Jörg Behrmann <behrmann@physik.fu-berlin.de>

* Drop /etc/default file

It was no longer being installed.

* Remove debian/compat file

This is managed by the control file nowadays
Diffstat (limited to '')
-rwxr-xr-xdebian/rules12
1 files changed, 7 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 5baf2475f0..3b79d56074 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,15 +6,17 @@
 # assume we only have one package
 PACKAGE_NAME:=`dh_listpackages`
 
-override_dh_systemd_enable:
-	dh_systemd_enable --name=matrix-synapse
-
-override_dh_installinit:
-	dh_installinit --name=matrix-synapse
+override_dh_installsystemd:
+	dh_installsystemd --name=matrix-synapse
 
 # we don't really want to strip the symbols from our object files.
 override_dh_strip:
 
+# many libraries pulled from PyPI have allocatable sections after
+# non-allocatable ones on which dwz errors out. For those without the issue the
+# gains are only marginal
+override_dh_dwz:
+
 # dh_shlibdeps calls dpkg-shlibdeps, which finds all the binary files
 # (executables and shared libs) in the package, and looks for the shared
 # libraries that they depend on. It then adds a dependency on the package that