summary refs log tree commit diff
path: root/debian/control
diff options
context:
space:
mode:
authorAmber Brown <hawkowl@atleastfornow.net>2018-12-11 04:14:34 +1100
committerRichard van der Hoff <richard@matrix.org>2018-12-20 11:15:52 +0000
commitfd4070a85dc4ece77f2427b586c18bb1f4a04197 (patch)
tree2f10f1098e20c3a1c8d44d3bdee6da074665f7b5 /debian/control
parent0.34.0rc2 (diff)
downloadsynapse-fd4070a85dc4ece77f2427b586c18bb1f4a04197.tar.xz
import from package-debian-synapse
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control77
1 files changed, 77 insertions, 0 deletions
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000000..854d9688f3
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,77 @@
+Source: matrix-synapse
+Maintainer: Erik Johnston <erikj@matrix.org>
+Section: python
+Priority: optional
+Build-Depends:
+ debhelper (>= 9),
+ dh-python,
+ dh-systemd (>= 1.5),
+ po-debconf,
+ python (>= 2.6.6-3),
+ python-bcrypt,
+ python-blist,
+ python-canonicaljson (>=1.1.3),
+ python-daemonize,
+ python-frozendict (>= 0.4),
+ python-lxml,
+ python-mock,
+ python-msgpack (>=0.3.0),
+ python-nacl (>= 0.3.0),
+ python-netaddr,
+ python-openssl (>= 0.14),
+ python-pil,
+ python-psutil,
+ python-pyasn1,
+ python-pydenticon,
+ python-pymacaroons-pynacl,
+ python-pysaml2,
+ python-service-identity (>= 1.0.0),
+ python-setuptools (>= 0.6b3),
+ python-signedjson (>= 1.0.0),
+ python-sortedcontainers,
+ python-syutil (>= 0.0.7),
+ python-treq (>= 15.1.0),
+ python-twisted (>= 17.1.0),
+ python-unpaddedbase64 (>= 1.0.1),
+ python-yaml,
+ python-phonenumbers (>= 8.2.0),
+ python-jsonschema (>=2.5.1),
+ python-prometheus-client,
+ python-attr
+Standards-Version: 3.9.8
+X-Python-Version: >= 2.7
+
+Package: matrix-synapse
+Architecture: all
+Depends:
+ ${misc:Depends},
+ ${python:Depends},
+ adduser,
+ debconf,
+ lsb-base (>= 3.0-6),
+ python-attr (>= 16.0.0),
+ python-twisted (>= 17.1.0),
+ python-canonicaljson (>=1.1.3),
+ python-prometheus-client (>=0.0.14),
+Suggests:
+ python-bleach (>= 1.4.2),
+ python-jinja2 (>= 2.8),
+Recommends:
+ python-psycopg2,
+ python-lxml,
+Description: Open federated Instant Messaging and VoIP server
+ Matrix is an ambitious new ecosystem for open federated Instant
+ Messaging and VoIP. Synapse is a reference Matrix server
+ implementation.
+ .
+ Everything in Matrix happens in a room.  Rooms are distributed and do
+ not exist on any single server.  Rooms can be located using
+ convenience aliases like #matrix:matrix.org or #test:localhost:8448.
+ .
+ Matrix user IDs look like @matthew:matrix.org (although in the future
+ you will normally refer to yourself and others using a 3PID: email
+ address, phone number, etc rather than manipulating Matrix user IDs)
+ .
+ The overall architecture is:
+ client <------> homeserver <=============> homeserver <------> client
+                 https://a.org/_matrix      https://b.net/_matrix