summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander von Gluck IV <kallisti5@unixzen.com>2021-02-03 14:39:49 -0600
committerAlexander von Gluck IV <kallisti5@unixzen.com>2021-02-03 14:39:49 -0600
commitcf00abc03e01849b2d322ab7ae39cc7c85cf740f (patch)
treee4fffb152a4ae7e0113ad07e83fdcf2c7a322eb2 /CMakeLists.txt
parentMerge pull request #445 from Jedi18/avatar_username_feature (diff)
downloadnheko-cf00abc03e01849b2d322ab7ae39cc7c85cf740f.tar.xz
cmake: Don't build with Werror on Haiku
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c9e29998..a3a62651 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -645,7 +645,7 @@ if(QML_DEBUGGING)
 endif()
 
 
-if(NOT MSVC)
+if(NOT MSVC AND NOT HAIKU)
 	if("${CMAKE_BUILD_TYPE}" STREQUAL "Debug" OR CI_BUILD)
 		target_compile_options(nheko PRIVATE "-Werror")
 	endif()