summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNicolas Werner <nicolas.werner@hotmail.de>2022-07-10 16:22:18 +0200
committerNicolas Werner <nicolas.werner@hotmail.de>2022-07-10 16:22:18 +0200
commitb654064cd9167bfc7b7c4ed9cef81b89e464b612 (patch)
tree69a63be023a933e59f7c838f150f2f00e4edc9a8 /CMakeLists.txt
parentFix rooms failing to load over dbus if image can't be downloaded (diff)
downloadnheko-b654064cd9167bfc7b7c4ed9cef81b89e464b612.tar.xz
Fix output name for flatpak
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4331d25..1efd7a4b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -663,6 +663,10 @@ else()
 	endif()
 endif()
 
+if (FLATPAK)
+	set_target_properties(nheko PROPERTIES OUTPUT_NAME "${APPID}")
+endif()
+
 if(APPLE)
 	target_link_libraries (nheko PRIVATE Qt5::MacExtras)
 elseif(WIN32)