summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKonstantinos Sideris <sideris.konstantin@gmail.com>2018-03-24 23:36:27 +0200
committerKonstantinos Sideris <sideris.konstantin@gmail.com>2018-03-24 23:36:27 +0200
commit97326243dbc578dc704cfa76a0e5cd01c4a9edc5 (patch)
treebd0b9be5ce40d70d66540c496695890bf7f09a4f /CMakeLists.txt
parentAdd basic support for username auto-completion (diff)
downloadnheko-97326243dbc578dc704cfa76a0e5cd01c4a9edc5.tar.xz
Link with pthread on Linux
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 020049e1..7931ee6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -131,6 +131,10 @@ if(CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID MATCHES "GNU")
     endif()
 endif()
 
+if(NOT APPLE AND NOT MSVC)
+  set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+endif()
+
 #
 # Declare source and header files.
 #