summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNicolas Werner <nicolas.werner@hotmail.de>2021-11-18 03:10:04 +0100
committerNicolas Werner <nicolas.werner@hotmail.de>2021-11-18 22:04:00 +0100
commit7f5a92106a023a96328bb5719bcec901c1374fc3 (patch)
tree6b8a291b46b4f6283a4d73fbb4e6eed818393c8a /CMakeLists.txt
parentFix hunter messing with pkg-config (diff)
downloadnheko-7f5a92106a023a96328bb5719bcec901c1374fc3.tar.xz
Try to fix lmdbxx download
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6340fc3c..6424f38f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -487,10 +487,10 @@ if(USE_BUNDLED_LMDBXX)
 		lmdbxx
 		URL "https://raw.githubusercontent.com/hoytech/lmdbxx/1.0.0/lmdb++.h"
 		DOWNLOAD_NO_EXTRACT TRUE
+		CONFIGURE_COMMAND ""
+		BUILD_COMMAND ""
 		)
-	if(NOT lmdbxx_POPULATED)
-		FetchContent_Populate(lmdbxx)
-	endif()
+	FetchContent_Populate(lmdbxx)
 	add_library(lmdbxx INTERFACE)
 	target_include_directories(lmdbxx INTERFACE ${lmdbxx_SOURCE_DIR})
 	add_library(lmdbxx::lmdbxx ALIAS lmdbxx)