summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNicolas Werner <nicolas.werner@hotmail.de>2021-11-21 21:19:56 +0100
committerNicolas Werner <nicolas.werner@hotmail.de>2021-11-21 21:19:56 +0100
commit71d7ff3a90f17be892678c122d4620fabfc5b05f (patch)
tree7bfa9cba5ec98d7a554cf1582c123a7ed4a9b8bb /CMakeLists.txt
parentOnly mark as direct, if invite was direct (diff)
downloadnheko-71d7ff3a90f17be892678c122d4620fabfc5b05f.tar.xz
Try to tame Windows headers
See also:
https://stackoverflow.com/questions/1394910/how-to-tame-the-windows-headers-useful-defines
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2352b799..4276d2f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -644,7 +644,7 @@ endif()
 
 if(WIN32)
 	add_executable (nheko WIN32 ${OS_BUNDLE} ${NHEKO_DEPS})
-	target_compile_definitions(nheko PRIVATE _WIN32_WINNT=0x0601)
+	target_compile_definitions(nheko PRIVATE _WIN32_WINNT=0x0601 NOMINMAX WIN32_LEAN_AND_MEAN STRICT)
 else()
 	add_executable (nheko ${OS_BUNDLE} ${NHEKO_DEPS})