summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoseph Donofry <rubberduckie3554@gmail.com>2023-06-15 19:08:22 -0400
committerJoseph Donofry <rubberduckie3554@gmail.com>2023-06-15 19:16:50 -0400
commit024486c989eca3a7ae679ddd6bd3dd00a7aad94d (patch)
tree2f8cd7132f5ed37c9b80844db322fb45a9602954 /CMakeLists.txt
parentTranslated using Weblate (Estonian) (diff)
downloadnheko-024486c989eca3a7ae679ddd6bd3dd00a7aad94d.tar.xz
Maybe fix macOS deployment (intel for now)
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 60cbe6ea..3feb49f5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -804,6 +804,20 @@ if(MAN)
 	add_subdirectory(man)
 endif()
 
+# potential workaround for macdeployqt issues
+if(APPLE)
+    install(TARGETS nheko
+        BUNDLE  DESTINATION .
+        RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+    )
+    qt_generate_deploy_qml_app_script(
+        TARGET nheko
+        OUTPUT_SCRIPT deploy_script
+        NO_UNSUPPORTED_PLATFORM_ERROR
+    )
+    install(SCRIPT ${deploy_script}) 
+endif()
+
 if(UNIX AND NOT APPLE)
 	if(FLATPAK)
 		set(APPID "im.nheko.Nheko")