summary refs log tree commit diff
path: root/host/Rory-portable/optional/gui/wayland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-portable/optional/gui/wayland.nix')
-rw-r--r--host/Rory-portable/optional/gui/wayland.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/host/Rory-portable/optional/gui/wayland.nix b/host/Rory-portable/optional/gui/wayland.nix
new file mode 100644
index 0000000..eac6391
--- /dev/null
+++ b/host/Rory-portable/optional/gui/wayland.nix
@@ -0,0 +1,37 @@
+{
+  pkgs,
+  ...
+}:
+
+{
+  programs.sway = {
+    enable = true;
+
+    wrapperFeatures.gtk = true;
+    extraSessionCommands = ''
+      # -- Wayland fixes
+      # SDL:
+      export SDL_VIDEODRIVER=wayland
+      # QT (needs qt5.qtwayland in systemPackages):
+      export QT_QPA_PLATFORM=wayland-egl
+      export QT_WAYLAND_DISABLE_WINDOWDECORATION="1"
+      # Fix for some Java AWT applications (e.g. Android Studio),
+      # use this if they aren't displayed properly:
+      export _JAVA_AWT_WM_NONREPARENTING=1
+    '';
+
+    extraPackages = with pkgs; [
+      swaybg
+      #swayidle
+      #swaylock
+      waybar
+      wl-clipboard
+      grim
+      slurp
+      easyeffects
+      keepassxc
+    ];
+  };
+
+  xdg.portal.wlr.enable = true;
+}