summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix48
1 files changed, 45 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index de69e78..eeaadba 100755
--- a/flake.nix
+++ b/flake.nix
@@ -23,6 +23,7 @@
 
     # Draupnir module/package
     nixpkgs-Draupnir.url = "github:TheArcaneBrony/nixpkgs/master";
+    #MatrixContentFilter.url = "git+file:/home/Rory/git/matrix/MatrixContentFilter?submodules=1";
 
     # Base modules
     home-manager.url = "github:nix-community/home-manager/master";
@@ -62,7 +63,47 @@
     with inputs;
     {
       nixosConfigurations = {
-        #NIXPKGS FORK
+        micro = nixpkgs.lib.nixosSystem {
+          system = "x86_64-linux";
+          modules = [
+            ./hardware-configuration.nix
+            #MatrixContentFilter.modules.default
+
+            (
+              { ... }:
+              {
+                boot.isContainer = true;
+                system.stateVersion = "0";
+                #services.MatrixContentFilter = {
+                #  enable = true;
+                #  accessTokenPath = "/";
+                #  appSettings = {
+                #    "Logging" = {
+                #      "LogLevel" = {
+                #        "Default" = "Debug";
+                #        "System" = "Information";
+                #        "Microsoft" = "Information";
+                #      };
+                #    };
+                #    "LibMatrixBot" = {
+                #      "Homeserver" = "rory.gay";
+                #      "Prefixes" = [
+                #        "!mcf "
+                #      ];
+                #      "MentionPrefix" = false;
+                #    };
+                #    "MatrixContentFilter" = {
+                #      Admins = [ "@emma:rory.gay" ];
+                #    };
+                #  };
+                #};
+              }
+            )
+          ];
+          #specialArgs = {
+          #  inherit home-manager;
+          #};
+        };
         Rory-nginx = nixpkgs.lib.nixosSystem {
           system = "x86_64-linux";
           modules = [
@@ -70,6 +111,7 @@
             ./hardware-configuration.nix
             home-manager.nixosModules.home-manager
             grapevine.nixosModules.default
+            #MatrixContentFilter.modules.default
 
             # these arent really modules...
             botcore-v4.modules.bots
@@ -101,7 +143,7 @@
             inherit conduit;
             inherit nixpkgs-Draupnir;
             #inherit conduwuit;
-            
+
             inherit (inputs) draupnirSrc;
           };
         };
@@ -219,7 +261,7 @@
         );
 
         packages.mtxclient-git = (pkgs.callPackage ./modules/packages/mtxclient-git.nix { inherit mtxclientSrc; });
-        
+
         # untested
         packages.draupnir-main = pkgs.draupnir.overrideAttrs (oldAttrs: {
           src = draupnirSrc;