summary refs log tree commit diff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorOlivier Wilkinson (reivilibre) <oliverw@matrix.org>2022-12-19 20:01:22 +0000
committerOlivier Wilkinson (reivilibre) <oliverw@matrix.org>2022-12-19 20:20:35 +0000
commit5ebd31c34999df6e8d3beeb2837d8ee401617bc9 (patch)
tree252975129d638044b890276f349dfce6be4cafc1 /pyproject.toml
parentAdd log line so we can see what's going on (diff)
downloadsynapse-5ebd31c34999df6e8d3beeb2837d8ee401617bc9.tar.xz
Add Scalene
Diffstat (limited to '')
-rw-r--r--pyproject.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 938aae64ca..518ea22ff8 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -210,6 +210,8 @@ parameterized = { version = ">=0.7.4", optional = true }
 idna = { version = ">=2.5", optional = true }
 pyicu = { version = ">=2.10.2", optional = true }
 
+scalene = { version = ">=1.5.16", optional = true, python = ">=3.8,<4.0.0" }
+
 [tool.poetry.extras]
 # NB: Packages that should be part of `pip install matrix-synapse[all]` need to be specified
 # twice: once here, and once in the `all` extra.
@@ -236,6 +238,8 @@ test = ["parameterized", "idna"]
 # Debian-based distributions).
 user-search = ["pyicu"]
 
+scalene = ["scalene"]
+
 # The duplication here is awful. I hate hate hate hate hate it. However, for now I want
 # to ensure you can still `pip install matrix-synapse[all]` like today. Two motivations:
 # 1) for new installations, I want instructions in existing documentation and tutorials