{
root = "/data/nginx/html_rory_gay";
enableACME = true;
addSSL = true;
extraConfig = ''
autoindex on;'';
locations."= /.well-known/matrix/server".extraConfig = ''
add_header Content-Type application/json;
add_header Access-Control-Allow-Origin *;
return 200 '${builtins.toJSON {
"m.server" = "matrix.rory.gay:443";
}}}';
'';
locations."= /.well-known/matrix/client".extraConfig = ''
add_header Content-Type application/json;
add_header Access-Control-Allow-Origin *;
return 200 '${builtins.toJSON {
"m.homeserver".base_url = "https://matrix.rory.gay";
"m.identity_server" = {};
}
}';
'';
}