summary refs log tree commit diff
path: root/modules/users/db2k.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/users/db2k.nix')
-rwxr-xr-xmodules/users/db2k.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/users/db2k.nix b/modules/users/db2k.nix
new file mode 100755
index 0000000..a6dc7cd
--- /dev/null
+++ b/modules/users/db2k.nix
@@ -0,0 +1,16 @@
+{ config, pkgs, ... }:
+
+{
+  users.groups.db2k = {};
+  users.users.db2k = {
+    isSystemUser = true;
+    extraGroups = [ "ocp" ];
+    group = "db2k";
+    home = "/data/nginx/html_git/.ocp";
+    shell = "${pkgs.git}/bin/git-shell";
+    openssh.authorizedKeys.keys = [
+      "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIMfXA4Oh0LZqY8LAS/lnANKVDBlemHGPWdtep1GE/LId garyzipperer09@gmail.com"
+    ];
+  };
+}
+