summary refs log tree commit diff
path: root/modules/users/Rory.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/users/Rory.nix')
-rwxr-xr-xmodules/users/Rory.nix124
1 files changed, 116 insertions, 8 deletions
diff --git a/modules/users/Rory.nix b/modules/users/Rory.nix
index daafb15..25ab725 100755
--- a/modules/users/Rory.nix
+++ b/modules/users/Rory.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, home-manager, ... }:
+{ config, lib, pkgs, home-manager, ... }:
 
 {
 
@@ -19,17 +19,125 @@
   };
 
   home-manager.users.Rory = {
-    programs.git = {
-      enable = true;
-      userName = "TheArcaneBrony";
-      userEmail = "myrainbowdash949@gmail.com";
-      extraConfig = {
-        safe = {
-          directory = "/";
+    #services.gnome-keyring.enable = true;
+    
+    programs = {
+      git = {
+        enable = true;
+        userName = "TheArcaneBrony";
+        userEmail = "myrainbowdash949@gmail.com";
+        extraConfig = {
+          safe = {
+            directory = "/";
+          };
         };
       };
+      zsh = {
+        enable = true;
+        enableAutosuggestions = true;
+        enableVteIntegration = true;
+        autocd = true;
+
+        initExtra = ''
+          alias ls='lsd -lA --color=always --icon=always'
+          '';
+        oh-my-zsh = {
+          enable = true;
+          plugins = [
+            "git"
+            "sudo"
+            "zsh-syntax-highlighting"
+            "zsh-autosuggetsions"
+          ];
+        };
+        #plugins = [
+        #  "git"
+        #  "zsh-syntax-highlighting"
+        #  "zsh-autosuggestions"
+        #];
+
+          plugins = [
+            {
+              name = "powerlevel10k";
+              src = pkgs.zsh-powerlevel10k;
+              file = "share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
+            }
+            #{
+            #  name = "powerlevel10k-config";
+            #  src = lib.cleanSource ./p10k-config;
+            #  file = "p10k.zsh";
+            #} 
+        ];
+
+
+
+        localVariables = {
+          POWERLEVEL9K_LEFT_PROMPT_ELEMENTS = [
+            "os_icon"
+            "dir"
+            "vcs"
+            "prompt_char"
+          ];
+          POWERLEVEL9K_RIGHT_PROMPT_ELEMENTS = [
+            "status"
+            "command_execution_time"
+            "background_jobs"
+            "direnv"
+            "virtualenv"
+            "pyenv"
+            "nodeenv"
+            "context"
+            "nix_shell"
+            "vi_mode"
+            "load"
+            "disk_usage"
+            "ram"
+          ];
+          POWERLEVEL9K_MODE = "nerdfont-complete";
+          POWERLEVEL9K_ICON_PADDING = "none";
+          POWERLEVEL9K_PROMPT_ADD_NEWLINE = "false";
+          POWERLEVEL9K_LEFT_SUBSEGMENT_SEPARATOR = "\uE0B1";
+          POWERLEVEL9K_RIGHT_SUBSEGMENT_SEPARATOR = "\uE0B3";
+          POWERLEVEL9K_LEFT_SEGMENT_SEPARATOR = "\uE0B0";
+          POWERLEVEL9K_RIGHT_SEGMENT_SEPARATOR = "\uE0B2";
+          POWERLEVEL9K_LEFT_PROMPT_LAST_SEGMENT_END_SYMBOL = "\uE0B0";
+          POWERLEVEL9K_RIGHT_PROMPT_FIRST_SEGMENT_START_SYMBOL = "\uE0B2";
+          POWERLEVEL9K_PROMPT_CHAR_OVERWRITE_STATE = true;
+        };
+      };
+      neovim = {
+        defaultEditor = true;
+        viAlias = true;
+        vimAlias = true;
+        vimdiffAlias = true;
+        coc = {
+          enable = true;
+          
+        };
+      };
+    };
+
+    # keepassxc, maybe?
+    systemd.user.services.keepassxc = {
+      Unit = {
+        Description = "KeePassXC password manager";
+        #After = [ "graphical-session-pre.target" ];
+        PartOf = [ "default.target" ];
+      };
+
+      Install = { WantedBy = [ "default.target" ]; };
+
+      Service = { ExecStart = "${pkgs.keepassxc}/bin/keepassxc ~/.secrets.kdbx"; };
     };
 
+    programs.neovim.plugins = with pkgs.vimPlugins; [
+      pkgs.vimPlugins.nvim-tree-lua
+      {
+        plugin = pkgs.vimPlugins.vim-startify;
+        config = "let g:startify_change_to_vcs_root = 0";
+      }
+    ];
+
     home.stateVersion = "22.11";
   };
 }