summary refs log tree commit diff
path: root/modules/packages/vim.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/packages/vim.nix')
-rwxr-xr-xmodules/packages/vim.nix16
1 files changed, 11 insertions, 5 deletions
diff --git a/modules/packages/vim.nix b/modules/packages/vim.nix
index 3524e2c..eaec336 100755
--- a/modules/packages/vim.nix
+++ b/modules/packages/vim.nix
@@ -1,14 +1,20 @@
 { pkgs, ... }:
 {
-  environment.variables = { EDITOR = "vim"; };
+  environment.variables = {
+    EDITOR = "vim";
+  };
 
   environment.systemPackages = with pkgs; [
     (neovim.override {
       vimAlias = true;
       configure = {
         packages.myPlugins = with pkgs.vimPlugins; {
-          start = [ vim-lastplace vim-nix vim-airline ]; 
-          opt = [];
+          start = [
+            vim-lastplace
+            vim-nix
+            vim-airline
+          ];
+          opt = [ ];
         };
         customRC = ''
           " your custom vimrc
@@ -17,6 +23,6 @@
           " ...
         '';
       };
-    }
-  )];
+    })
+  ];
 }