summary refs log tree commit diff
path: root/modules/monitoring/system.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/monitoring/system.nix')
-rw-r--r--modules/monitoring/system.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/modules/monitoring/system.nix b/modules/monitoring/system.nix
index cc1ec66..171a7af 100644
--- a/modules/monitoring/system.nix
+++ b/modules/monitoring/system.nix
@@ -46,13 +46,13 @@ in
       ];
     };
 
-    services.prometheus.scrapeConfigs = (
-        lib.map (interval: {
-            job_name = "node-${toString interval}s";
-            scrape_interval = "${toString interval}s";
-            static_configs = [ { targets = [ "localhost:${toString config.services.prometheus.exporters.node.port}" ]; } ];
-        }) cfg.prometheusScrapeIntervals
-    );
+    services.prometheus.scrapeConfigs = [
+      {
+        job_name = "node";
+        scrape_interval = "${toString cfg.prometheusScrapeInterval}s";
+        static_configs = [ { targets = [ "localhost:${toString config.services.prometheus.exporters.node.port}" ]; } ];
+      }
+    ];
 
     services.grafana.provision.dashboards.settings = {
       apiVersion = 1;