summary refs log tree commit diff
path: root/modules/monitoring/synapse.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/monitoring/synapse.nix')
-rw-r--r--modules/monitoring/synapse.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/modules/monitoring/synapse.nix b/modules/monitoring/synapse.nix
index dcb389a..a279a3d 100644
--- a/modules/monitoring/synapse.nix
+++ b/modules/monitoring/synapse.nix
@@ -10,7 +10,7 @@ in
         type = "metrics";
         port = 9200;
         tls = false;
-        resources = [];
+        resources = [ ];
       }
     ];
 
@@ -56,7 +56,7 @@ in
               {
                 type = "metrics";
                 port = 9200 + index + 1;
-                resources = [];
+                resources = [ ];
               }
             ];
           };
@@ -77,7 +77,12 @@ in
           lib.map (interval: {
             job_name = "synapse-${workerName}-${toString interval}s";
             scrape_interval = "${toString interval}s";
-            static_configs = [ { targets = [ "localhost:${toString (9200 + index + 1)}" ]; } ];
+            static_configs = [ 
+            { 
+            targets = [ "localhost:${toString (9200 + index + 1)}" ];
+            
+             } 
+            ];
             metrics_path = "_synapse/metrics";
           }) cfg.prometheusScrapeIntervals
         ) config.monitoring.synapse.workerNames