summary refs log tree commit diff
path: root/modules/base-client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/base-client.nix')
-rwxr-xr-xmodules/base-client.nix61
1 files changed, 61 insertions, 0 deletions
diff --git a/modules/base-client.nix b/modules/base-client.nix
new file mode 100755
index 0000000..1f482ee
--- /dev/null
+++ b/modules/base-client.nix
@@ -0,0 +1,61 @@
+{ config, pkgs, lib, ... }:
+
+{
+  imports =
+    [
+      ./base.nix
+    ];
+
+  networking = {
+    hostName = lib.mkDefault "Rory-nix-base";
+    firewall = {
+      enable = false;
+      # allowedTCPPorts = [ ... ];
+      # allowedUDPPorts = [ ... ];
+    };
+  };
+
+  i18n.defaultLocale = "en_US.UTF-8";
+
+  systemd = {
+    sleep.extraConfig = ''
+      AllowSuspend=no
+      AllowHibernation=no
+      '';
+  };
+
+  environment.systemPackages = with pkgs; [
+    # - cli utils
+    sshfs
+
+    # - gui utils
+    gnome-console
+    cinnamon.nemo
+    feh
+    udisks
+    gparted
+  ];
+
+  fonts.fonts = with pkgs; [
+    (nerdfonts.override { fonts = [ "JetBrainsMono" ]; })
+  ];
+
+  systemd.coredump.extraConfig = lib.mkDefault ''
+    Storage=none
+  '';
+  nix = {
+    settings = {
+      experimental-features = [ "nix-command" "flakes" ];
+      auto-optimise-store = true;
+    };
+  };
+  nixpkgs = {
+    config.allowUnfree = true;
+  };
+  security = {
+    polkit.enable = true;
+    sudo.wheelNeedsPassword = false;
+  };
+
+  system.stateVersion = "22.11"; # DO NOT EDIT!
+}