summary refs log tree commit diff
path: root/host/Rory-wsl/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-wsl/configuration.nix')
-rw-r--r--host/Rory-wsl/configuration.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/host/Rory-wsl/configuration.nix b/host/Rory-wsl/configuration.nix
new file mode 100644
index 0000000..35eaff5
--- /dev/null
+++ b/host/Rory-wsl/configuration.nix
@@ -0,0 +1,46 @@
+{ lib, pkgs, config, modulesPath, ... }:
+
+{
+  wsl = {
+    enable = true;
+    automountPath = "/mnt";
+    defaultUser = "nixos";
+    startMenuLaunchers = true;
+
+    # Enable native Docker support
+    # docker-native.enable = true;
+
+    # Enable integration with Docker Desktop (needs to be installed)
+    # docker-desktop.enable = true;
+
+  };
+
+  nix.extraOptions = ''
+    experimental-features = nix-command flakes
+  '';
+
+  environment.systemPackages = with pkgs; [
+    wget
+    neofetch
+    lnav
+    git
+    lsd
+    duf
+    htop
+    btop
+    kitty.terminfo
+    jq
+    yq
+    pv
+    dig
+    cinnamon.nemo
+    gnome-console
+    kitty
+    feh
+    vimPlugins.vim-nix
+    neovim
+    tree
+  ];
+
+  system.stateVersion = "23.05";
+}