summary refs log tree commit diff
path: root/host/Rory-portable/nginx/discord.localhost.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-portable/nginx/discord.localhost.nix')
-rwxr-xr-xhost/Rory-portable/nginx/discord.localhost.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/host/Rory-portable/nginx/discord.localhost.nix b/host/Rory-portable/nginx/discord.localhost.nix
deleted file mode 100755
index b40e13c..0000000
--- a/host/Rory-portable/nginx/discord.localhost.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{ pkgs, ... }:
-
-{
-  root = "/www/discord";
-  addSSL = true;
-  enableACME = false;
-
-  # We don't care about certificates around here...
-  sslCertificate = "${pkgs.path}/nixos/tests/common/acme/server/acme.test.cert.pem";
-  sslCertificateKey = "${pkgs.path}/nixos/tests/common/acme/server/acme.test.key.pem";
-
-  extraConfig = ''
-    autoindex on;
-    more_set_headers 'Access-Control-Allow-Origin: *';
-    more_set_headers 'Access-Control-Allow-Methods: GET, POST, OPTIONS';
-    more_set_headers 'Access-Control-Allow-Headers: DNT,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type,Range';
-    more_set_headers 'Access-Control-Expose-Headers: Content-Length,Content-Range';
-    more_set_headers 'Access-Control-Allow-Credentials: true';
-  '';
-
-  locations = {
-    "/" = {
-      index = "index.html";
-      extraConfig = ''
-        more_set_headers 'Access-Control-Allow-Origin: *';
-        more_set_headers 'Access-Control-Allow-Methods: *';
-        more_set_headers 'Access-Control-Allow-Headers: *';
-        more_set_headers 'Access-Control-Expose-Headers: *';
-        more_set_headers 'Access-Control-Max-Age' 1728000;
-
-        # default to /index.html if file not found
-        try_files $uri $uri/ /index.html;
-      '';
-    };
-  };
-}