summary refs log tree commit diff
path: root/host/Rory-portable/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-portable/configuration.nix')
-rw-r--r--host/Rory-portable/configuration.nix67
1 files changed, 8 insertions, 59 deletions
diff --git a/host/Rory-portable/configuration.nix b/host/Rory-portable/configuration.nix
index ebfe899..e278e17 100644
--- a/host/Rory-portable/configuration.nix
+++ b/host/Rory-portable/configuration.nix
@@ -1,5 +1,4 @@
 {
-  config,
   pkgs,
   lib,
   nhekoSrc,
@@ -9,19 +8,8 @@
 
 {
   imports = [
-    # base imports
     ../../modules/base-client.nix
     ../../modules/packages/vim.nix
-    #      ../../modules/environments/home.nix
-    #../../modules/software-templates/profilers.nix
-    #./postgres.nix
-    #./nginx.nix
-
-    # hardware-specific imports
-    #./optional/hardware-specific/amd.nix
-
-    #./printing.nix
-    ./ollama.nix
   ];
 
   boot = {
@@ -80,7 +68,6 @@
 
   services.power-profiles-daemon.enable = true;
   time.timeZone = "Europe/Brussels";
-  i18n.defaultLocale = "en_US.UTF-8";
 
   services = {
     libinput.touchpad.naturalScrolling = true;
@@ -123,21 +110,6 @@
 
   sound.enable = true;
 
-  users.users = {
-    Rory = {
-      isNormalUser = true;
-      extraGroups = [ "wheel" ];
-      packages = with pkgs; [
-        #gimp-with-plugins
-
-        #xterm
-        #gnomeExtensions.vitals
-        #gnomeExtensions.runcat
-      ];
-      initialPassword = "password";
-    };
-  };
-
   environment.systemPackages = with pkgs; [
     libreoffice
     qt6.qtwayland
@@ -165,8 +137,8 @@
 
     # - Languages
     #dotnet-sdk_7
-    #dotnet-sdk_8
-    (callPackage ../../modules/packages/dotnet-pack.nix { inherit pkgs; })
+    dotnet-sdk_8
+    #(callPackage ../../modules/packages/dotnet-pack.nix { inherit pkgs; })
 
     #games
     osu-lazer-bin
@@ -176,8 +148,8 @@
     # extra packages
     dmenu
 
-    cinnamon.nemo
-    gnome.file-roller
+    nemo
+    file-roller
     firefox-bin
     ungoogled-chromium # needed for Rider in order to debug WASM
 
@@ -237,37 +209,14 @@
       (nerdfonts.override { fonts = [ "JetBrainsMono" ]; })
       noto-fonts-monochrome-emoji
     ];
-    fontconfig.defaultFonts.monospace = with pkgs; [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
-    fontconfig.defaultFonts.sansSerif = with pkgs; [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
-    fontconfig.defaultFonts.serif = with pkgs; [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
-    fontconfig.defaultFonts.emoji = with pkgs; [ "freefont" ];
+    fontconfig.defaultFonts.monospace = [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
+    fontconfig.defaultFonts.sansSerif = [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
+    fontconfig.defaultFonts.serif = [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
+    fontconfig.defaultFonts.emoji = [ "freefont" ];
     enableDefaultPackages = lib.mkForce false;
     enableGhostscriptFonts = lib.mkForce false;
   };
-  nix = {
-    settings = {
-      experimental-features = [
-        "nix-command"
-        "flakes"
-      ];
-      auto-optimise-store = true;
-    };
-  };
-  nixpkgs = {
-    config = {
-      allowUnfree = true;
-      permittedInsecurePackages = [ "electron-25.9.0" ];
-    };
 
-  };
-  security = {
-    polkit.enable = true;
-    sudo.wheelNeedsPassword = false;
-  };
-
-  hardware = {
-    pulseaudio.enable = false;
-  };
   programs.dconf.enable = true;
   environment.etc."resolv.conf".text = ''
     nameserver 8.8.8.8