summary refs log tree commit diff
path: root/host/Rory-portable/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-portable/configuration.nix')
-rw-r--r--host/Rory-portable/configuration.nix99
1 files changed, 50 insertions, 49 deletions
diff --git a/host/Rory-portable/configuration.nix b/host/Rory-portable/configuration.nix
index 71ace4c..ebfe899 100644
--- a/host/Rory-portable/configuration.nix
+++ b/host/Rory-portable/configuration.nix
@@ -1,22 +1,28 @@
-{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
+{
+  config,
+  pkgs,
+  lib,
+  nhekoSrc,
+  mtxclientSrc,
+  ...
+}:
 
 {
-  imports =
-    [
-      # base imports
-      ../../modules/base-client.nix
-      ../../modules/packages/vim.nix
-#      ../../modules/environments/home.nix
-      #../../modules/software-templates/profilers.nix
-      #./postgres.nix
-      #./nginx.nix
-
-      # hardware-specific imports
-      #./optional/hardware-specific/amd.nix
-
-      #./printing.nix
-      ./ollama.nix
-    ];
+  imports = [
+    # base imports
+    ../../modules/base-client.nix
+    ../../modules/packages/vim.nix
+    #      ../../modules/environments/home.nix
+    #../../modules/software-templates/profilers.nix
+    #./postgres.nix
+    #./nginx.nix
+
+    # hardware-specific imports
+    #./optional/hardware-specific/amd.nix
+
+    #./printing.nix
+    ./ollama.nix
+  ];
 
   boot = {
     kernelPackages = pkgs.linuxPackages_latest;
@@ -61,7 +67,7 @@
     #  address = "192.168.0.3";
     #  prefixLength = 24;
     #} ];
-#
+    #
     #defaultGateway = "192.168.0.1";
     # useDHCP = true;
   };
@@ -98,13 +104,13 @@
     picom.enable = true;
     picom.vSync = false;
     picom.backend = "glx";
-    
+
     openssh = {
       enable = true;
       extraConfig = ''
         MaxAuthTries 32
-        '';
-    };	
+      '';
+    };
     pipewire = {
       enable = true;
       audio.enable = true;
@@ -148,15 +154,14 @@
     #jetbrains.webstorm
     #jetbrains.clion
     github-copilot-intellij-agent
-    
-    
+
     dbeaver-bin
     #insomnia
     vscode
 
     # - Utilities
     inkscape-with-extensions
-    gimp #-with-plugins
+    gimp # -with-plugins
 
     # - Languages
     #dotnet-sdk_7
@@ -174,14 +179,18 @@
     cinnamon.nemo
     gnome.file-roller
     firefox-bin
-    ungoogled-chromium #needed for Rider in order to debug WASM
+    ungoogled-chromium # needed for Rider in order to debug WASM
 
     peek
 
     unrar-wrapper
 
     #(schildichat-desktop.override { electron = electron; })
-    (callPackage ../../modules/packages/nheko-git.nix { inherit nhekoSrc; inherit mtxclientSrc; voipSupport = false; })
+    (callPackage ../../modules/packages/nheko-git.nix {
+      inherit nhekoSrc;
+      inherit mtxclientSrc;
+      voipSupport = false;
+    })
     #(callPackage ../../modules/packages/mc/server/modpack/curseforge/techopolis-2/5.4.nix { })
 
     #vesktop
@@ -201,7 +210,7 @@
   #];
   xdg = {
     portal = {
-      
+
       enable = true;
       extraPortals = with pkgs; [
         #xdg-desktop-portal-gtk
@@ -228,33 +237,26 @@
       (nerdfonts.override { fonts = [ "JetBrainsMono" ]; })
       noto-fonts-monochrome-emoji
     ];
-    fontconfig.defaultFonts.monospace = with pkgs; [
-      "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular"
-    ];
-    fontconfig.defaultFonts.sansSerif = with pkgs; [
-      "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular"
-    ];
-    fontconfig.defaultFonts.serif = with pkgs; [
-      "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular"
-    ];
-    fontconfig.defaultFonts.emoji = with pkgs; [
-      "freefont"
-    ];
+    fontconfig.defaultFonts.monospace = with pkgs; [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
+    fontconfig.defaultFonts.sansSerif = with pkgs; [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
+    fontconfig.defaultFonts.serif = with pkgs; [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
+    fontconfig.defaultFonts.emoji = with pkgs; [ "freefont" ];
     enableDefaultPackages = lib.mkForce false;
     enableGhostscriptFonts = lib.mkForce false;
   };
   nix = {
     settings = {
-      experimental-features = [ "nix-command" "flakes" ];
+      experimental-features = [
+        "nix-command"
+        "flakes"
+      ];
       auto-optimise-store = true;
     };
   };
   nixpkgs = {
     config = {
       allowUnfree = true;
-      permittedInsecurePackages = [
-        "electron-25.9.0"
-      ];
+      permittedInsecurePackages = [ "electron-25.9.0" ];
     };
 
   };
@@ -272,17 +274,16 @@
     nameserver 8.4.4.8
     nameserver 1.1.1.1
     nameserver 1.0.0.1
-    '';
+  '';
 
-    #networking.wireguard.interfaces = {
-    #  wg-KP-Ran = {
+  #networking.wireguard.interfaces = {
+  #  wg-KP-Ran = {
 
-      #};
-   # };
+  #};
+  # };
 
   virtualisation.libvirtd.enable = true;
   programs.virt-manager.enable = true;
 
   system.stateVersion = "22.11"; # DO NOT EDIT!
 }
-