summary refs log tree commit diff
path: root/host/Rory-nginx/services/nginx/rory.gay/pcpoc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/nginx/rory.gay/pcpoc.nix')
-rwxr-xr-xhost/Rory-nginx/services/nginx/rory.gay/pcpoc.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/host/Rory-nginx/services/nginx/rory.gay/pcpoc.nix b/host/Rory-nginx/services/nginx/rory.gay/pcpoc.nix
index 2e502c7..ce00d28 100755
--- a/host/Rory-nginx/services/nginx/rory.gay/pcpoc.nix
+++ b/host/Rory-nginx/services/nginx/rory.gay/pcpoc.nix
@@ -1,9 +1,17 @@
 {
   enableACME = true;
   addSSL = true;
+  quic = true;
+  http3 = true;
+  http3_hq = true;
+  kTLS = true;
+  reuseport = true;
+  extraConfig = ''
+    brotli off;
+    '';
   locations = {
     "/" = {
-      proxyPass = "http://192.168.100.10";
+      proxyPass = "http://192.168.100.10:80";
     };
   };
 }
\ No newline at end of file