summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/background.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/workers/background.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/background.nix15
1 files changed, 6 insertions, 9 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/background.nix b/host/Rory-nginx/services/matrix/synapse/workers/background.nix
index 501299a..611f6eb 100644
--- a/host/Rory-nginx/services/matrix/synapse/workers/background.nix
+++ b/host/Rory-nginx/services/matrix/synapse/workers/background.nix
@@ -1,23 +1,20 @@
-{
-  config,
-  pkgs,
-  lib,
-  ...
-}:
+{ config, lib, ... }:
 
 let
   cfg = config.services.matrix-synapse;
+  workerName = "background";
+  workerRoutes = [ ];
 in
 {
   services.matrix-synapse = lib.mkIf cfg.enableBackgroundWorker {
     settings = {
       instance_map = {
         background = {
-          path = "/run/matrix-synapse/background.sock";
+          path = "/run/matrix-synapse/${workerName}.sock";
         };
       };
 
-      run_background_tasks_on = "background";
+      run_background_tasks_on = workerName;
     };
 
     workers = {
@@ -26,7 +23,7 @@ in
         worker_listeners = [
           {
             type = "http";
-            path = "/run/matrix-synapse/background.sock";
+            path = "/run/matrix-synapse/${workerName}.sock";
             resources = [
               {
                 names = [ "replication" ];