summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/ratelimits.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/ratelimits.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/ratelimits.nix56
1 files changed, 56 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/ratelimits.nix b/host/Rory-nginx/services/matrix/synapse/ratelimits.nix
new file mode 100644
index 0000000..8165fe4
--- /dev/null
+++ b/host/Rory-nginx/services/matrix/synapse/ratelimits.nix
@@ -0,0 +1,56 @@
+{
+  rc_message = {
+    per_second = 1000;
+    burst_count = 1000;
+  };
+  rc_login = {
+    address = {
+      per_second = 1000;
+      burst_count = 1000;
+    };
+    account = {
+      per_second = 1000;
+      burst_count = 1000;
+    };
+    failed_attempts = {
+      per_second = 0.1;
+      burst_count = 3;
+    };
+  };
+  rc_joins = {
+    local = {
+      per_second = 1000;
+      burst_count = 1000;
+    };
+    remote = {
+      per_second = 1000;
+      burst_count = 1000;
+    };
+  };
+  rc_joins_per_room = {
+    per_second = 1000;
+    burst_count = 1000;
+  };
+  rc_invites = {
+    per_room = {
+      per_second = 1000;
+      burst_count = 1000;
+    };
+    per_user = {
+      per_second = 1000;
+      burst_count = 1000;
+    };
+    per_issuer = {
+      per_second = 1000;
+      burst_count = 1000;
+    };
+  };
+  rc_federation = {
+    window_size = 10;
+    sleep_limit = 1000;
+    sleep_delay = 100;
+    reject_limit = 1000;
+    concurrent = 100;
+  };
+  federation_rr_transactions_per_room_per_second = 1;
+}
\ No newline at end of file