summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/db.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/matrix/synapse/db.nix')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/db.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/db.nix b/host/Rory-nginx/services/matrix/synapse/db.nix
new file mode 100644
index 0000000..c5edc51
--- /dev/null
+++ b/host/Rory-nginx/services/matrix/synapse/db.nix
@@ -0,0 +1,21 @@
+{ 
+  workerName ? null,
+  dbGroup ? null
+}: {
+  name = "psycopg2";
+  args = {
+    user = "matrix-synapse-rory-gay";
+    password = "somepassword";
+    database = "matrix-synapse-rory-gay";
+    host = "/run/postgresql";
+    application_name = "matrix-synapse (rory.gay) - ${if workerName == null then throw "synapse/db.nix: workerName unspecified" else workerName}";
+    cp_min = if dbGroup == "small" then 2
+      else if dbGroup == "medium" then 5
+      else if dbGroup == "large" then 10
+      else throw "synapse/db.nix: Invalid dbGroup: ${if dbGroup == null then "null" else dbGroup}";
+    cp_max = if dbGroup == "small" then 2
+      else if dbGroup == "medium" then 10
+      else if dbGroup == "large" then 10
+      else throw "synapse/db.nix: Invalid dbGroup: ${if dbGroup == null then "null" else dbGroup}";
+  };
+}
\ No newline at end of file