summary refs log tree commit diff
path: root/host/Rory-nginx/services/containers/matrixunittests/container.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/containers/matrixunittests/container.nix')
-rwxr-xr-xhost/Rory-nginx/services/containers/matrixunittests/container.nix43
1 files changed, 29 insertions, 14 deletions
diff --git a/host/Rory-nginx/services/containers/matrixunittests/container.nix b/host/Rory-nginx/services/containers/matrixunittests/container.nix
index 597b1cf..5273b4e 100755
--- a/host/Rory-nginx/services/containers/matrixunittests/container.nix
+++ b/host/Rory-nginx/services/containers/matrixunittests/container.nix
@@ -1,26 +1,41 @@
-{ pkgs, lib, conduit, ... }:
+{
+  pkgs,
+  lib,
+  conduit,
+  ...
+}:
 
 {
   privateNetwork = true;
   autoStart = true;
   specialArgs = {
     inherit conduit;
-  };  
-  config = { lib, pkgs, conduit, ... }: {
-    imports = [ ./root.nix ];
-    environment.etc."resolv.conf".text = ''
-      nameserver 8.8.8.8
-      nameserver 8.4.4.8
-      nameserver 1.1.1.1
-      nameserver 1.0.0.1
+  };
+  config =
+    {
+      lib,
+      pkgs,
+      conduit,
+      ...
+    }:
+    {
+      imports = [ ./root.nix ];
+      environment.etc."resolv.conf".text = ''
+        nameserver 8.8.8.8
+        nameserver 8.4.4.8
+        nameserver 1.1.1.1
+        nameserver 1.0.0.1
       '';
-    networking.firewall = {
-      enable = true;
-      allowedTCPPorts = [ 80 5432 ];
+      networking.firewall = {
+        enable = true;
+        allowedTCPPorts = [
+          80
+          5432
+        ];
+      };
     };
-  };  
   hostAddress = "192.168.100.12";
   localAddress = "192.168.100.13";
   hostAddress6 = "fc00::3";
   localAddress6 = "fc00::4";
-}
\ No newline at end of file
+}