summary refs log tree commit diff
path: root/host/Rory-nginx/services/containers/draupnir-linux-mint/root.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/containers/draupnir-linux-mint/root.nix')
-rwxr-xr-xhost/Rory-nginx/services/containers/draupnir-linux-mint/root.nix34
1 files changed, 6 insertions, 28 deletions
diff --git a/host/Rory-nginx/services/containers/draupnir-linux-mint/root.nix b/host/Rory-nginx/services/containers/draupnir-linux-mint/root.nix
index bea6255..2254695 100755
--- a/host/Rory-nginx/services/containers/draupnir-linux-mint/root.nix
+++ b/host/Rory-nginx/services/containers/draupnir-linux-mint/root.nix
@@ -1,31 +1,6 @@
-{
-  config,
-  pkgs,
-  lib,
-  ...
-}:
+{ pkgs, ... }:
 
 {
-  imports = [
-    ./services/draupnir.nix
-  ];
-
-  environment.systemPackages = with pkgs; [
-    neofetch
-    lnav
-    zsh
-    lsd
-    htop
-    btop
-    duf
-    kitty.terminfo
-    neovim
-    jq
-    yq
-    pv
-    dig
-  ];
-
   environment.etc."resolv.conf".text = ''
     nameserver 8.8.8.8
     nameserver 8.4.4.8
@@ -34,9 +9,12 @@
   '';
 
   networking.hosts = {
-    "192.168.100.18" = [ "matrix.rory.gay" "rory.gay" ];
+    "192.168.100.18" = [
+      "matrix.rory.gay"
+      "rory.gay"
+    ];
   };
-  
+
   networking.firewall = {
     enable = true;
   };