summary refs log tree commit diff
path: root/host/Rory-nginx/services/containers/draupnir-cme/services/draupnir.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/containers/draupnir-cme/services/draupnir.nix')
-rwxr-xr-xhost/Rory-nginx/services/containers/draupnir-cme/services/draupnir.nix13
1 files changed, 3 insertions, 10 deletions
diff --git a/host/Rory-nginx/services/containers/draupnir-cme/services/draupnir.nix b/host/Rory-nginx/services/containers/draupnir-cme/services/draupnir.nix
index c23680c..cf59809 100755
--- a/host/Rory-nginx/services/containers/draupnir-cme/services/draupnir.nix
+++ b/host/Rory-nginx/services/containers/draupnir-cme/services/draupnir.nix
@@ -1,14 +1,10 @@
-{
-  config,
-  pkgs,
-  lib,
-  ...
-}:
+{ ... }:
 
 {
   services.draupnir = {
     enable = true;
     accessTokenFile = "/etc/draupnir-access-token";
+    homeserverUrl = "https://matrix.rory.gay";
 
     settings = {
       managementRoom = "#draupnir-cme:rory.gay";
@@ -16,15 +12,12 @@
       autojoinOnlyIfManager = true; # ... but we don't want the bot to be invited to eg. Matrix HQ...
       automaticallyRedactForReasons = [ "*" ]; # Always autoredact
       fasterMembershipChecks = true;
-      homeserverUrl = "https://matrix.rory.gay";
 
       backgroundDelayMS = 10; # delay isn't needed, I don't mind the performance hit
       pollReports = false;
 
       admin.enableMakeRoomAdminCommand = false;
-      commands.ban.defaultReasons = [
-        "spam"
-      ];
+      commands.ban.defaultReasons = [ "spam" ];
     };
   };
 }