summary refs log tree commit diff
path: root/host/Rory-nginx/services/containers/conduwuit-throwaway/container.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/services/containers/conduwuit-throwaway/container.nix')
-rwxr-xr-xhost/Rory-nginx/services/containers/conduwuit-throwaway/container.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/containers/conduwuit-throwaway/container.nix b/host/Rory-nginx/services/containers/conduwuit-throwaway/container.nix
new file mode 100755
index 0000000..b8781e7
--- /dev/null
+++ b/host/Rory-nginx/services/containers/conduwuit-throwaway/container.nix
@@ -0,0 +1,26 @@
+{ pkgs, lib, conduit, ... }:
+
+{
+  privateNetwork = true;
+  autoStart = true;
+  specialArgs = {
+    inherit conduit;
+  };  
+  config = { lib, pkgs, conduit, ... }: {
+    imports = [ ./root.nix ];
+    environment.etc."resolv.conf".text = ''
+      nameserver 8.8.8.8
+      nameserver 8.4.4.8
+      nameserver 1.1.1.1
+      nameserver 1.0.0.1
+      '';
+    networking.firewall = {
+      enable = true;
+      allowedTCPPorts = [ 80 5432 ];
+    };
+  };  
+  hostAddress = "192.168.100.16";
+  localAddress = "192.168.100.17";
+  hostAddress6 = "fc00::5";
+  localAddress6 = "fc00::6";
+}
\ No newline at end of file