summary refs log tree commit diff
path: root/host/Rory-nginx/hosts/rory.gay/root.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-nginx/hosts/rory.gay/root.nix')
-rwxr-xr-xhost/Rory-nginx/hosts/rory.gay/root.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/host/Rory-nginx/hosts/rory.gay/root.nix b/host/Rory-nginx/hosts/rory.gay/root.nix
index 8fb3837..96aacba 100755
--- a/host/Rory-nginx/hosts/rory.gay/root.nix
+++ b/host/Rory-nginx/hosts/rory.gay/root.nix
@@ -21,4 +21,30 @@
     }
     }';
   ''; 
+  locations."= /.well-known/matrix/support".extraConfig = ''
+    add_header Content-Type application/json;
+    add_header Access-Control-Allow-Origin *;
+    return 200 '${builtins.toJSON {
+      admins = {
+        {
+          matrix_id = "@emma:rory.gay";
+          role = "admin";
+        },
+	      {
+          matrix_id = "@alicia:rory.gay";
+          role = "admin";
+        },
+	      {
+          matrix_id = "@root:rory.gay";
+          role = "admin";
+        },
+      	{
+          matrix_id = "@rory:rory.gay";
+          role = "admin";
+        }
+      }
+    }
+    }';
+  ''; 
+  
 }