summary refs log tree commit diff
path: root/host/Rory-desktop/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-desktop/configuration.nix')
-rw-r--r--host/Rory-desktop/configuration.nix51
1 files changed, 4 insertions, 47 deletions
diff --git a/host/Rory-desktop/configuration.nix b/host/Rory-desktop/configuration.nix
index 42176d0..ed4f501 100644
--- a/host/Rory-desktop/configuration.nix
+++ b/host/Rory-desktop/configuration.nix
@@ -14,6 +14,9 @@
       # hardware-specific imports
       ./optional/hardware-specific/amd.nix
 
+      ./optional/gui/x11.nix
+      ./optional/gui/wayland.nix
+
       ./printing.nix
       ./ollama.nix
     ];
@@ -71,42 +74,11 @@
     xserver = {
       enable = true;
       updateDbusEnvironment = true;
-      #videoDrivers = ["amdgpu"]; #"nvidia"
-      #desktopManager.gnome.enable = true;
       libinput.enable = true;
       layout = "us";
-      windowManager.i3.enable = true;
-      windowManager.i3.extraSessionCommands = ''
-        # output from arandr:
-        #xrandr --output DP-1 --mode 1920x1080 --pos 3840x1080 --rotate normal --output HDMI-1 --mode 3840x2160 --pos 0x0 --rotate normal --output HDMI-2 --off --output DP-2 --off
-        xrandr --output HDMI-1 --mode 3840x2160 --pos 0x0 --rotate normal --primary --output DP-1 --mode 1920x1080 --pos 3840x1080 --rotate normal --output HDMI-2 --off --output DP-2 --off
-        ${pkgs.polybarFull}/bin/polybar &
-        ${pkgs.dunst}/bin/dunst &
-        ${pkgs.feh}/bin/feh --no-fehbg --bg-fill ${../../modules/users/Rory/wallpaper.webp}
-      '';
       wacom.enable = true;
     };
-    picom.enable = true;
-    picom.vSync = false;
-    picom.backend = "glx";
-    #gnome = {
-    #  core-developer-tools.enable = false;
-    #  core-utilities.enable = false;
-    #  tracker-miners.enable = false;
-    #  tracker.enable = false;
-    #  sushi.enable = false;
-    #  rygel.enable = false;
-    #  gnome-user-share.enable = false;
-    #  gnome-remote-desktop.enable = false;
-    #  gnome-online-miners.enable = lib.mkForce false;
-    #  gnome-online-accounts.enable = false;
-    #  gnome-initial-setup.enable = false;
-    #  gnome-browser-connector.enable = false;
-    #  games.enable = false;
-    #  gnome-keyring.enable = lib.mkForce false;
-    #  evolution-data-server.enable = lib.mkForce false;
-    #  at-spi2-core.enable = lib.mkForce false;
-    #};
+    
     openssh = {
       enable = true;
       extraConfig = ''
@@ -125,21 +97,6 @@
 
   sound.enable = true;
 
-  users.users = {
-    Rory = {
-      isNormalUser = true;
-      extraGroups = [ "wheel" ];
-      packages = with pkgs; [
-        #gimp-with-plugins
-
-        #xterm
-        #gnomeExtensions.vitals
-        #gnomeExtensions.runcat
-      ];
-      initialPassword = "password";
-    };
-  };
-
   environment.systemPackages = with pkgs; [
     libreoffice
     qt6.qtwayland