summary refs log tree commit diff
path: root/host/Rory-desktop/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-desktop/configuration.nix')
-rw-r--r--host/Rory-desktop/configuration.nix113
1 files changed, 58 insertions, 55 deletions
diff --git a/host/Rory-desktop/configuration.nix b/host/Rory-desktop/configuration.nix
index 756a894..73b361f 100644
--- a/host/Rory-desktop/configuration.nix
+++ b/host/Rory-desktop/configuration.nix
@@ -1,26 +1,32 @@
-args@{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
+args@{
+  config,
+  pkgs,
+  lib,
+  nhekoSrc,
+  mtxclientSrc,
+  ...
+}:
 
 {
-  imports =
-    [
-      # base imports
-      ../../modules/base-client.nix
-      # (import ../../modules/base-secrets.nix {  path = "/home/rory/.config/sops/config.yaml"; })
-      ../../modules/packages/vim.nix
-#      ../../modules/environments/home.nix
-      ../../modules/software-templates/profilers.nix
-      ./postgres.nix
-      ./nginx.nix
-
-      # hardware-specific imports
-      ./optional/hardware-specific/amd.nix
-
-      ./optional/gui/x11.nix
-      ./optional/gui/wayland.nix
-
-      #./printing.nix
-      ./ollama.nix
-    ];
+  imports = [
+    # base imports
+    ../../modules/base-client.nix
+    # (import ../../modules/base-secrets.nix {  path = "/home/rory/.config/sops/config.yaml"; })
+    ../../modules/packages/vim.nix
+    #      ../../modules/environments/home.nix
+    ../../modules/software-templates/profilers.nix
+    ./postgres.nix
+    ./nginx.nix
+
+    # hardware-specific imports
+    ./optional/hardware-specific/amd.nix
+
+    ./optional/gui/x11.nix
+    ./optional/gui/wayland.nix
+
+    #./printing.nix
+    ./ollama.nix
+  ];
 
   boot = {
     kernelPackages = pkgs.linuxPackages_latest;
@@ -63,10 +69,12 @@ args@{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
       # allowedUDPPorts = [ ... ];
     };
 
-    interfaces.enp34s0.ipv4.addresses = [ { 
-      address = "192.168.0.3";
-      prefixLength = 24;
-    } ];
+    interfaces.enp34s0.ipv4.addresses = [
+      {
+        address = "192.168.0.3";
+        prefixLength = 24;
+      }
+    ];
 
     defaultGateway = "192.168.0.1";
     # useDHCP = true;
@@ -85,14 +93,14 @@ args@{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
       wacom.enable = true;
     };
     libinput.enable = true;
-    
+
     openssh = {
       enable = true;
       extraConfig = ''
         MaxAuthTries 32
-        '';
+      '';
       settings.PermitRootLogin = "yes";
-    };	
+    };
     pipewire = {
       enable = true;
       audio.enable = true;
@@ -121,15 +129,14 @@ args@{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
     #jetbrains.webstorm
     #jetbrains.clion
     github-copilot-intellij-agent
-    
-    
+
     dbeaver-bin
     #insomnia
     vscode
 
     # - Utilities
     inkscape-with-extensions
-    gimp #-with-plugins
+    gimp # -with-plugins
 
     # - Languages
     #dotnet-sdk_7
@@ -159,7 +166,11 @@ args@{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
     unrar-wrapper
 
     #(schildichat-desktop.override { electron = electron; })
-    (callPackage ../../modules/packages/nheko-git.nix { inherit nhekoSrc; inherit mtxclientSrc; voipSupport = false; })
+    (callPackage ../../modules/packages/nheko-git.nix {
+      inherit nhekoSrc;
+      inherit mtxclientSrc;
+      voipSupport = false;
+    })
     #(callPackage ../../modules/packages/mc/server/modpack/curseforge/techopolis-2/5.4.nix { })
 
     #vesktop
@@ -178,7 +189,7 @@ args@{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
   #];
   xdg = {
     portal = {
-      
+
       enable = true;
       extraPortals = with pkgs; [
         #xdg-desktop-portal-gtk
@@ -205,33 +216,26 @@ args@{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
       (nerdfonts.override { fonts = [ "JetBrainsMono" ]; })
       noto-fonts-monochrome-emoji
     ];
-    fontconfig.defaultFonts.monospace = with pkgs; [
-      "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular"
-    ];
-    fontconfig.defaultFonts.sansSerif = with pkgs; [
-      "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular"
-    ];
-    fontconfig.defaultFonts.serif = with pkgs; [
-      "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular"
-    ];
-    fontconfig.defaultFonts.emoji = with pkgs; [
-      "freefont"
-    ];
+    fontconfig.defaultFonts.monospace = with pkgs; [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
+    fontconfig.defaultFonts.sansSerif = with pkgs; [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
+    fontconfig.defaultFonts.serif = with pkgs; [ "JetBrainsMonoNL Nerd Font,JetBrainsMonoNL NF:style=Regular" ];
+    fontconfig.defaultFonts.emoji = with pkgs; [ "freefont" ];
     enableDefaultPackages = lib.mkForce false;
     enableGhostscriptFonts = lib.mkForce false;
   };
   nix = {
     settings = {
-      experimental-features = [ "nix-command" "flakes" ];
+      experimental-features = [
+        "nix-command"
+        "flakes"
+      ];
       auto-optimise-store = true;
     };
   };
   nixpkgs = {
     config = {
       allowUnfree = true;
-      permittedInsecurePackages = [
-        "electron-25.9.0"
-      ];
+      permittedInsecurePackages = [ "electron-25.9.0" ];
     };
 
   };
@@ -249,17 +253,16 @@ args@{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
     nameserver 8.4.4.8
     nameserver 1.1.1.1
     nameserver 1.0.0.1
-    '';
+  '';
 
-    #networking.wireguard.interfaces = {
-    #  wg-KP-Ran = {
+  #networking.wireguard.interfaces = {
+  #  wg-KP-Ran = {
 
-      #};
-   # };
+  #};
+  # };
 
   virtualisation.libvirtd.enable = true;
   programs.virt-manager.enable = true;
 
   system.stateVersion = "22.11"; # DO NOT EDIT!
 }
-