summary refs log tree commit diff
path: root/host/Rory-desktop/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-desktop/configuration.nix')
-rw-r--r--host/Rory-desktop/configuration.nix97
1 files changed, 52 insertions, 45 deletions
diff --git a/host/Rory-desktop/configuration.nix b/host/Rory-desktop/configuration.nix
index be7f4b2..a34fc1c 100644
--- a/host/Rory-desktop/configuration.nix
+++ b/host/Rory-desktop/configuration.nix
@@ -7,6 +7,9 @@
       ../../modules/packages/vim.nix
 #      ../../modules/environments/home.nix
       ../../modules/software-templates/profilers.nix
+      ./postgres.nix
+      ./mariadb.nix
+      ./nginx.nix
     ];
 
     boot = {
@@ -50,42 +53,40 @@
       enable = true;
       updateDbusEnvironment = true;
       videoDrivers = ["nvidia"];
-      #videoDrivers = [ "intel" ];
-      #desktopManager.gnome.enable = true;
+      desktopManager.gnome.enable = true;
       libinput.enable = true;
       layout = "us";
-      #modules = [ pkgs.xorg.xf86videointel ];
       windowManager.i3.enable = true;
-      #windowManager.i3.extraPackages = with pkgs; [ ];
       windowManager.i3.extraSessionCommands = ''
-        xrandr --output DP-5 --auto --pos -1920x1080
-        xrandr --output HDMI-0 --auto --primary --pos 1920x0
-        polybar &
-        dunst &
+        # output from arandr:
+        xrandr --output DP-0 --off --output DP-1 --off --output DP-2 --off --output DP-3 --off --output HDMI-0 --primary --mode 3840x2160 --pos 0x0 --rotate normal --output DP-4 --off --output DP-5 --mode 1920x1080 --pos 3840x1080 --rotate normal
+        ${pkgs.polybarFull}/bin/polybar &
+        ${pkgs.dunst}/bin/dunst &
+        ${pkgs.feh}/bin/feh --no-fehbg --bg-fill ${../../modules/users/Rory/wallpaper.webp}
       '';
       wacom.enable = true;
     };
     picom.enable = true;
     picom.vSync = false;
     picom.backend = "glx";
-    #gnome = {
-    #  core-developer-tools.enable = false;
-    #  core-utilities.enable = false;
-    #  tracker-miners.enable = false;
-    #  tracker.enable = false;
-    #  sushi.enable = false;
-    #  rygel.enable = false;
-    #  gnome-user-share.enable = false;
-    #  gnome-remote-desktop.enable = false;
-    #  gnome-online-miners.enable = lib.mkForce false;
-    #  gnome-online-accounts.enable = false;
-    #  gnome-initial-setup.enable = false;
-    #  gnome-browser-connector.enable = false;
-    #  games.enable = false;
-    #  gnome-keyring.enable = lib.mkForce false;
-    #  evolution-data-server.enable = lib.mkForce false;
-    #  at-spi2-core.enable = lib.mkForce false;
-    #};
+    gnome = {
+      core-developer-tools.enable = false;
+      core-utilities.enable = false;
+      tracker-miners.enable = false;
+      tracker.enable = false;
+      sushi.enable = false;
+      rygel.enable = false;
+      gnome-user-share.enable = false;
+      gnome-remote-desktop.enable = false;
+      gnome-online-miners.enable = lib.mkForce false;
+      gnome-online-accounts.enable = false;
+      gnome-initial-setup.enable = false;
+      gnome-browser-connector.enable = false;
+      games.enable = false;
+      gnome-keyring.enable = lib.mkForce false;
+      evolution-data-server.enable = lib.mkForce false;
+      at-spi2-core.enable = lib.mkForce false;
+    };
     openssh = {
       enable = true;
       extraConfig = ''
@@ -120,6 +121,7 @@
   };
 
   environment.systemPackages = with pkgs; [
+    qt6.qtwayland
 
     gnome-console
     feh
@@ -130,6 +132,7 @@
     # - IDEs
     jetbrains-toolbox
     jetbrains.rider
+    jetbrains.webstorm
     github-copilot-intellij-agent
     
     
@@ -154,9 +157,6 @@
 
     # extra packages
     dmenu
-    i3status
-    polybarFull
-    dunst
 
     cinnamon.nemo
     gnome.file-roller
@@ -171,10 +171,11 @@
 
     unrar-wrapper
 
-    (schildichat-desktop.override { electron = electron; })
+    #(schildichat-desktop.override { electron = electron; })
     (callPackage ../../modules/packages/nheko-git.nix { inherit nhekoSrc; inherit mtxclientSrc; voipSupport = false; })
     #(callPackage ../../modules/packages/mc/server/modpack/curseforge/techopolis-2/5.4.nix { })
   ];
+
   programs.steam.enable = true;
   programs.steam.gamescopeSession.enable = true;
 
@@ -183,20 +184,20 @@
   #  pkgs.gnome-tour
   #  pkgs.gnome-user-docs
   #];
-  xdg = {
-    portal = {
-      enable = true;
-      extraPortals = with pkgs; [
-        xdg-desktop-portal-gtk
-      ];
-      xdgOpenUsePortal = true;
-    };
-    sounds.enable = true;
-    mime.enable = true;
-    menus.enable = true;
-    icons.enable = true;
-    autostart.enable = true;
-  };
+  #xdg = {
+  #  portal = {
+  #    enable = true;
+  #    extraPortals = with pkgs; [
+  #      xdg-desktop-portal-gtk
+  #    ];
+  #    xdgOpenUsePortal = true;
+  #  };
+  #  sounds.enable = true;
+  #  mime.enable = true;
+  #  menus.enable = true;
+  #  icons.enable = true;
+  #  autostart.enable = true;
+  #};
   fonts = {
     fonts = with pkgs; [
       (nerdfonts.override { fonts = [ "JetBrainsMono" ]; })
@@ -224,7 +225,13 @@
     };
   };
   nixpkgs = {
-    config.allowUnfree = true;
+    config = {
+      allowUnfree = true;
+      permittedInsecurePackages = [
+        "electron-25.9.0"
+      ];
+    };
+
   };
   security = {
     polkit.enable = true;