summary refs log tree commit diff
path: root/host/Rory-desktop/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/Rory-desktop/configuration.nix')
-rw-r--r--host/Rory-desktop/configuration.nix18
1 files changed, 15 insertions, 3 deletions
diff --git a/host/Rory-desktop/configuration.nix b/host/Rory-desktop/configuration.nix
index 3e21734..aa09659 100644
--- a/host/Rory-desktop/configuration.nix
+++ b/host/Rory-desktop/configuration.nix
@@ -24,8 +24,8 @@ args@{
     ./optional/gui/x11.nix
     ./optional/gui/wayland.nix
 
-    ./printing.nix
-    #./ollama.nix
+    #./printing.nix
+#    ./ollama.nix
   ];
 
   boot = {
@@ -230,7 +230,7 @@ args@{
   nixpkgs = {
     config = {
       allowUnfree = true;
-      permittedInsecurePackages = [ 
+      permittedInsecurePackages = [
         "electron-25.9.0"
         "olm-3.2.16"
       ];
@@ -262,5 +262,17 @@ args@{
   virtualisation.libvirtd.enable = true;
   programs.virt-manager.enable = true;
 
+  monitoring = {
+    monitorAll = true;
+    localPrometheus = true;
+    exposePrometheus = true;
+    localGrafana = true;
+    exposeGrafana = true;
+    nginxHost = "monitoring.localhost";
+    nginxSsl = false;
+  };
+  networking.hosts."127.0.0.1" = builtins.attrNames config.services.nginx.virtualHosts;
+  
+
   system.stateVersion = "22.11"; # DO NOT EDIT!
 }