summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix20
1 files changed, 18 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 07e9dce..a30d9a8 100755
--- a/flake.nix
+++ b/flake.nix
@@ -28,9 +28,20 @@
       inputs.nixpkgs.follows = "nixpkgs";
     };
     nixos-wsl.url = "github:nix-community/NixOS-WSL";
+    #inputs.nur.url = github:nix-community/NUR;
+
+    # Sources...
+    nhekoSrc = {
+      url = "github:Nheko-reborn/nheko/master";
+      flake = false;
+    };
+    mtxclientSrc = {
+      url = "github:Nheko-reborn/mtxclient/master";
+      flake = false;
+    };
   };
 
-  outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, conduit, nixos-wsl }: {
+  outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, conduit, nixos-wsl, ... }@inputs: {
     nixosConfigurations = {
       #NIXPKGS FORK
       Rory-nginx = nixpkgs-rory.lib.nixosSystem {
@@ -90,8 +101,13 @@
           nixos-wsl.nixosModules.default
           ./host/Rory-wsl/configuration.nix
 #          ./hardware-configuration.nix
-	  home-manager.nixosModules.home-manager
+	        home-manager.nixosModules.home-manager
+          #nur.nixosModules.nur
         ];
+        specialArgs = {
+          inherit (inputs) mtxclientSrc;
+          inherit (inputs) nhekoSrc;
+        };
       };
     };
   };