summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index cb3c792..f27d066 100755
--- a/flake.nix
+++ b/flake.nix
@@ -25,6 +25,9 @@
       # will probably also require you to always build from source.
       #inputs.nixpkgs.follows = "nixpkgs";
     };
+    conduit-vanilla = {
+      url = "gitlab:famedly/conduit";
+    };
     nixos-wsl.url = "github:nix-community/NixOS-WSL";
     #inputs.nur.url = github:nix-community/NUR;
 
@@ -50,7 +53,7 @@
     };
   };
 
-  outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, MatrixMediaGate, conduit, nixos-wsl, ... }@inputs: {
+  outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, MatrixMediaGate, conduit, conduit-vanilla, nixos-wsl, ... }@inputs: {
     nixosConfigurations = {
       #NIXPKGS FORK
       Rory-nginx = nixpkgs-rory.lib.nixosSystem {
@@ -64,6 +67,7 @@
           inherit botcore-v4;
           inherit home-manager;
           inherit conduit;
+          inherit conduit-vanilla;
           inherit MatrixMediaGate;
         };
       };