summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rwxr-xr-xflake.nix48
1 files changed, 13 insertions, 35 deletions
diff --git a/flake.nix b/flake.nix
index 300496b..f5fca4e 100755
--- a/flake.nix
+++ b/flake.nix
@@ -1,7 +1,8 @@
 {
-  description = "Rory's services flake";
+  description = "Rory&'s services flake";
 
   inputs = {
+    # Different nixpkgs versions
     nixpkgs = {
       url = "github:NixOS/nixpkgs/nixos-unstable";
       #url="path:/Rory-Open-Architecture/nixpkgs";
@@ -17,42 +18,24 @@
       url = "github:NixOS/nixpkgs/nixos-23.11";
     };
 
-    home-manager =  {
-      url = "github:nix-community/home-manager/master";
-    };
-
-    conduit = {
-      #url = "gitlab:famedly/conduit";
-
-      #url = "github:girlbossceo/conduwuit/7ecc570bb8a07aba9802fd0217f978583f55bc8b";
-      #url = "github:girlbossceo/conduwuit";
-      url = "gitlab:matrix/grapevine-fork?host=gitlab.computer.surgery&ref=benjamin/debug-emma-kde-room";
-      # Assuming you have an input for nixpkgs called `nixpkgs`. If you experience
-      # build failures while using this, try commenting/deleting this line. This
-      # will probably also require you to always build from source.
-      #inputs.nixpkgs.follows = "nixpkgs";
-    };
-
-    conduit-vanilla = {
-      url = "gitlab:famedly/conduit/next";
-    };
+    # Base modules
+    home-manager.url = "github:nix-community/home-manager/master";
+    sops-nix.url = "github:Mic92/sops-nix";
 
+    # Packages
+    grapevine.url = "gitlab:matrix/grapevine-fork?host=gitlab.computer.surgery&ref=benjamin/debug-emma-kde-room";
+    conduit.url = "gitlab:famedly/conduit/next";
     nixos-wsl.url = "github:nix-community/NixOS-WSL";
 
     # Own projects
-
     botcore-v4 = {
       url = "gitlab:BotCore-Devs/BotCore-v4/staging";
+      inputs.nixpkgs.follows = "nixpkgs";
     };
 
-    #MatrixMediaGate = {
-    #  url = "git+https://cgit.rory.gay/matrix/tools/MatrixMediaGate.git/";
-    #};
-
     # Sources...
     nhekoSrc = {
       url = "github:Nheko-reborn/nheko/master";
-      #url = "github:q234rty/nheko/b34bce70a4b6572330a6abcfe7b75ce123567f1e";
       flake = false;
     };
     mtxclientSrc = {
@@ -61,7 +44,7 @@
     };
   };
 
-  outputs = { self, nixpkgs, nixpkgs-RoryNix, nixpkgs-rory, home-manager, botcore-v4, conduit, conduit-vanilla, nixos-wsl, ... }@inputs: {
+  outputs = inputs: with inputs; {
     nixosConfigurations = {
       #NIXPKGS FORK
       Rory-nginx = nixpkgs-rory.lib.nixosSystem {
@@ -70,13 +53,13 @@
           ./host/Rory-nginx/configuration.nix
           ./hardware-configuration.nix
           home-manager.nixosModules.home-manager
-          conduit.nixosModules.default
+          grapevine.nixosModules.default
         ];
         specialArgs = {
           inherit botcore-v4;
           inherit home-manager;
+          inherit grapevine;
           inherit conduit;
-          inherit conduit-vanilla;
         };
       };
 
@@ -99,6 +82,7 @@
           ./host/Rory-desktop/configuration.nix
           ./hardware-configuration.nix
           home-manager.nixosModules.home-manager
+          sops-nix.nixosModules.sops
           ({...}: { 
             nix = {
               registry.nixpkgs.flake = nixpkgs;
@@ -107,12 +91,6 @@
               ];
             };
           })
-          # ... add this line to the rest of your configuration modules
-          #nix-ld.nixosModules.nix-ld
-
-          # The module in this repository defines a new module under (programs.nix-ld.dev) instead of (programs.nix-ld) 
-          # to not collide with the nixpkgs version.
-          #{ programs.nix-ld.dev.enable = true; }
         ];
         specialArgs = {
           inherit home-manager;