summary refs log tree commit diff
path: root/host/Rory-portable/printing.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-06-10 17:33:26 +0200
committerRory& <root@rory.gay>2024-07-04 14:45:02 +0200
commite37b430512bbef89dfe8ab75454286de4836ab6e (patch)
treeaf3468855573725fefc29ab8935edcc663d6b6a3 /host/Rory-portable/printing.nix
parentBunch of changes (diff)
downloadRory-Open-Architecture-e37b430512bbef89dfe8ab75454286de4836ab6e.tar.xz
Add portable config, some updates
Diffstat (limited to '')
-rw-r--r--host/Rory-portable/printing.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/host/Rory-portable/printing.nix b/host/Rory-portable/printing.nix
new file mode 100644
index 0000000..fd33aaa
--- /dev/null
+++ b/host/Rory-portable/printing.nix
@@ -0,0 +1,51 @@
+{ config, pkgs, lib, ... }:
+
+{
+  imports = [ ];
+
+  users.users = {
+    Rory = {
+      extraGroups = [ "lp" "scanner" ];
+    };
+  };
+
+  environment.systemPackages = with pkgs; [
+    xsane
+    gnome.simple-scan
+  ];
+
+  hardware = {
+    sane.enable = true;
+    sane.extraBackends = [ pkgs.hplipWithPlugin pkgs.sane-airscan ];
+  };
+
+  programs.system-config-printer.enable = true;
+
+  services = {
+    gvfs.enable = true;
+    saned.enable = true;
+    system-config-printer.enable = true;
+    ipp-usb.enable = true;
+    printing = {
+      enable = true;
+      browsing = true;
+      drivers = with pkgs; [ hplip ];
+    };
+    avahi = {
+      enable = true;
+      nssmdns = true;
+      reflector = true;
+      publish = {
+        workstation = true;
+        userServices = true;
+        hinfo = true;
+        enable = true;
+        domain = true;
+        addresses = true;
+      };
+    };
+  };
+
+  system.stateVersion = "22.11"; # DO NOT EDIT!
+}
+