summary refs log tree commit diff
path: root/host/Rory-nginx/services/ollama.nix
diff options
context:
space:
mode:
authorRory&::Emma <root@rory.gay>2024-05-01 11:16:54 +0000
committerRory& <root@rory.gay>2024-07-04 14:45:02 +0200
commitc6d47d4a1c523ddabc3ca871685eda5ca74ca607 (patch)
tree14e1ff3942915ca8205d6f8859a46b13d66c7a70 /host/Rory-nginx/services/ollama.nix
parentFix package passthrough (diff)
downloadRory-Open-Architecture-c6d47d4a1c523ddabc3ca871685eda5ca74ca607.tar.xz
Server updates
Diffstat (limited to '')
-rwxr-xr-xhost/Rory-nginx/services/ollama.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/ollama.nix b/host/Rory-nginx/services/ollama.nix
new file mode 100755
index 0000000..8151fe3
--- /dev/null
+++ b/host/Rory-nginx/services/ollama.nix
@@ -0,0 +1,17 @@
+{ config, pkgs, lib, ... }:
+
+{
+#  systemd.tmpfiles.rules = [  "d /data/ollama 0750 ostgres postgres" ];
+
+  services.ollama = {
+    enable = true;
+    home = "/data/ollama/home";
+    models = "/data/ollama/home/models";
+    environmentVariables = {
+      OLLAMA_LLM_LIBRARY = "cpu";
+    };
+    writablePaths = [ "/data/ollama/home" ];
+    listenAddress = "0.0.0.0:11434";
+    sandbox = false;
+  };
+}