summary refs log tree commit diff
path: root/host/Rory-nginx/services/matrix/synapse/workers/module.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-07-04 21:30:36 +0200
committerRory& <root@rory.gay>2024-07-04 21:30:36 +0200
commit4c7d06161be711b11d5a2b6cfffb31599dd0ace6 (patch)
tree5c967a60ea1a20f12e64a63d87de06af925e0de6 /host/Rory-nginx/services/matrix/synapse/workers/module.nix
parentFix client readers (diff)
downloadRory-Open-Architecture-4c7d06161be711b11d5a2b6cfffb31599dd0ace6.tar.xz
Federation readers
Diffstat (limited to '')
-rw-r--r--host/Rory-nginx/services/matrix/synapse/workers/module.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/Rory-nginx/services/matrix/synapse/workers/module.nix b/host/Rory-nginx/services/matrix/synapse/workers/module.nix
index ebe4732..1450d52 100644
--- a/host/Rory-nginx/services/matrix/synapse/workers/module.nix
+++ b/host/Rory-nginx/services/matrix/synapse/workers/module.nix
@@ -19,6 +19,8 @@ in
     ./appservice.nix
     ./background.nix
     ./client-reader.nix
+    ./federation-inbound.nix
+    ./federation-reader.nix
     ./federation-sender.nix
     ./media-repo.nix
     ./pusher.nix
@@ -79,6 +81,16 @@ in
         default = 0;
         description = "Number of client readers";
       };
+      federationReaders = lib.mkOption {
+        type = lib.types.int;
+        default = 0;
+        description = "Number of federation readers";
+      };
+      federationInboundWorkers = lib.mkOption {
+        type = lib.types.int;
+        default = 0;
+        description = "Number of federation inbound workers";
+      };
 
       nginxVirtualHostName = lib.mkOption {
         type = lib.types.str;