summary refs log tree commit diff
path: root/host/Rory-nginx/configuration.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-09-10 03:02:41 +0200
committerRory& <root@rory.gay>2024-09-10 03:02:41 +0200
commit680316541c33d5dbcad7c59dba5586ecf3407c68 (patch)
tree7760b42296eb60638f2d9c9d65b0bbf3b9a61fd3 /host/Rory-nginx/configuration.nix
parentSynapse fixes (diff)
downloadRory-Open-Architecture-680316541c33d5dbcad7c59dba5586ecf3407c68.tar.xz
Override resolv.conf properly
Diffstat (limited to '')
-rwxr-xr-xhost/Rory-nginx/configuration.nix16
1 files changed, 7 insertions, 9 deletions
diff --git a/host/Rory-nginx/configuration.nix b/host/Rory-nginx/configuration.nix
index 539c96e..c875678 100755
--- a/host/Rory-nginx/configuration.nix
+++ b/host/Rory-nginx/configuration.nix
@@ -51,15 +51,14 @@
       enableIPv6 = false;
     };
     enableIPv6 = lib.mkForce false;
-    nameservers = lib.mkOverride [
-      "192.168.1.1"
-    ];
+    nameservers = lib.mkOverride [ "192.168.1.1" ];
+  };
+
+  environment.etc."resolv.conf" = lib.mkOverride {
+    text = ''
+      nameserver 192.168.1.1
+    '';
   };
-  
-  
-  environment.etc."resolv.conf".text = lib.mkOverride ''
-    nameserver 192.168.1.1
-  '';
 
   monitoring = {
     monitorAll = true;
@@ -100,6 +99,5 @@
 
   system.stateVersion = "22.11"; # DO NOT EDIT!
 
-
   environment.systemPackages = with pkgs; [ waypipe ];
 }