summary refs log tree commit diff
path: root/host/Rory-desktop/optional/gui/x11.nix
diff options
context:
space:
mode:
authorRory& <root@rory.gay>2024-06-12 18:46:14 +0200
committerRory& <root@rory.gay>2024-07-04 14:45:02 +0200
commitdf79ef9b9cfc0230935864b820b4cfaf30afafff (patch)
tree5526609fbee0aca7610ba24c0e931586e29b4984 /host/Rory-desktop/optional/gui/x11.nix
parentAdd portable config, some updates (diff)
downloadRory-Open-Architecture-df79ef9b9cfc0230935864b820b4cfaf30afafff.tar.xz
Desktop changes
Diffstat (limited to '')
-rw-r--r--host/Rory-desktop/optional/gui/x11.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/host/Rory-desktop/optional/gui/x11.nix b/host/Rory-desktop/optional/gui/x11.nix
new file mode 100644
index 0000000..4bf9fe4
--- /dev/null
+++ b/host/Rory-desktop/optional/gui/x11.nix
@@ -0,0 +1,26 @@
+{ config, pkgs, lib, nhekoSrc, mtxclientSrc, ... }:
+
+{
+  imports =
+    [ ];
+
+  services = {
+    xserver = {
+      windowManager.i3.enable = true;
+      windowManager.i3.extraSessionCommands = ''
+        # output from arandr:
+        #xrandr --output DP-1 --mode 1920x1080 --pos 3840x1080 --rotate normal --output HDMI-1 --mode 3840x2160 --pos 0x0 --rotate normal --output HDMI-2 --off --output DP-2 --off
+        xrandr --output HDMI-1 --mode 3840x2160 --pos 0x0 --rotate normal --primary --output DP-1 --mode 1920x1080 --pos 3840x1080 --rotate normal --output HDMI-2 --off --output DP-2 --off
+        ${pkgs.polybarFull}/bin/polybar &
+        ${pkgs.dunst}/bin/dunst &
+        ${pkgs.feh}/bin/feh --no-fehbg --bg-fill ${../../../../modules/users/Rory/wallpaper.webp}
+      '';
+    };
+
+    picom.enable = true;
+    picom.vSync = false;
+    picom.backend = "glx";
+  };
+
+}
+