summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorTheArcaneBrony <myrainbowdash949@gmail.com>2023-01-02 05:04:26 +0000
committerTheArcaneBrony <myrainbowdash949@gmail.com>2023-01-02 05:04:26 +0000
commit44cf7be2d93ab270b08196d5153a6eda0032a1ee (patch)
treefc8382ac93c76fa91d59b289cc9de8b11e0a5ceb /flake.nix
parentEnable spice and qemu guest additions (diff)
downloadRory-Open-Architecture-44cf7be2d93ab270b08196d5153a6eda0032a1ee.tar.xz
Add home manager
Signed-off-by: TheArcaneBrony <myrainbowdash949@gmail.com>
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 675a737..6def9bb 100644
--- a/flake.nix
+++ b/flake.nix
@@ -14,11 +14,14 @@
     discord-client-proxy = {
       url = "github:Fosscord/discord-client-proxy";
     };
+    home-manager =  {
+      url = "github:nix-community/home-manager/master";
+    };
   };
 
   # Outputs can be anything, but the wiki + some commands define their own
   # specific keys. Wiki page: https://nixos.wiki/wiki/Flakes#Output_schema
-  outputs = { self, nixpkgs, botcore-v4, discord-client-proxy }: {
+  outputs = { self, nixpkgs, home-manager, botcore-v4, discord-client-proxy }: {
     # nixosConfigurations is the key that nixos-rebuild looks for.
     nixosConfigurations = {
       Rory-discordbots = nixpkgs.lib.nixosSystem {
@@ -29,6 +32,7 @@
         ];
         specialArgs = {
           inherit botcore-v4;
+          inherit home-manager;
         };
       };
       Rory-fosscord = nixpkgs.lib.nixosSystem {
@@ -39,6 +43,7 @@
         ];
         specialArgs = {
           inherit discord-client-proxy;
+          inherit home-manager;
         };
       };
       Rory-postgres = nixpkgs.lib.nixosSystem {
@@ -47,6 +52,9 @@
           ./host/Rory-postgres/configuration.nix
           ./hardware-configuration.nix
         ];
+        specialArgs = {
+          inherit home-manager;
+        };
       };
       Rory-devenv = nixpkgs.lib.nixosSystem {
         system = "x86_64-linux";
@@ -54,6 +62,9 @@
           ./host/Rory-devenv/configuration.nix
           ./hardware-configuration.nix
         ];
+        specialArgs = {
+          inherit home-manager;
+        };
       };
     };
   };